SEARCH

The How-To Geek Forums Have Migrated to Discourse

How-To Geek Forums / Windows 7

Can't change Screen Orientation! Help!!!

(15 posts)
  • Started 1 year ago by kingamongthepigs
  • Latest reply from kingamongthepigs
  • Topic Viewed 1519 times

kingamongthepigs
Posts: 8

I have a HP Pavilion Dv6 laptop and I'm struggling to rotate my screen.
There's no drop down option for orientation in Screen Resolution menu

The same goes for Nvidia and Intel 's preferences screen.


I even tried this
HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Control\Class\{4D36E968-E325-11CE-BFC1-08002BE10318}000
Change the following two Reg_dword entries
Display1_RotationCaps to the value of 7
Display2_RotationCaps to the value of 7

which didn't work.
I'm on windows 7, Nvidia 650 and Intel HD 4000.

I mostly use the screen rotating feature for Firefox, so if there's any add-on that can archive the same thing it's fine too.

I wrote a small code using greasemonkey, something like this:

document.documentElement.style['transform'] = 'rotate(-90deg)';
document.documentElement.style['-moz-transform'] = 'rotate(-90deg)';
document.documentElement.style['-webkit-transform'] = 'rotate(-90deg)';

This enabled me to rotate the sites, with lots of bug though. But the biggest problem is of course, the mouse movements are still the same and aren't rotated ( up->right , right -> down, down-> left etc )

Any help appreciated. Thanks in advance.

Posted 1 year ago
Top
 
ronniesonora
Posts: 919

Try holding down the ctrl and alt keys and press the arrow keys.

Posted 1 year ago
Top
 
Xhi
Xhi
Posts: 6298

I would also suggest updating your video drivers,

Posted 1 year ago
Top
 
kingamongthepigs
Posts: 8

Hotkeys was the first thing I tried. All of my drivers are also alreadly up to date, still no luck :( Thanks for your help.
Any other ideas?

Posted 1 year ago
Top
 
Xhi
Xhi
Posts: 6298

Have you tried pressing the Detect button?

Posted 1 year ago
Top
 
Raffyb
Raffyb
Posts: 13

Hmm... that's strange holding down ctrl+alt and pressing one of the arrow keys should change the screen orientation.
Try rebooting your pc if that doesn't work scan your pc for viruses if that doesn't work try running a registry fixer if that doesn't work try a defragger if that doesn't work try a windows repair.

I suggest you use Tuneup Utilities 15 Day Trial

Posted 1 year ago
Top
 
mu-tron
mu-tron
Posts: 7

There's a couple of ways to sort this out -

push ctrl+alt+-> (or up arrow or other sideways arrow

Or you could try Catalyst Control Centre, i believe the HP Pavilion Dv6 laptop has a AMD Radeon HD graphics card and if you install the Catalyst Control Centre and right click your desktop it will show AMD Engine Control Centre, click on that and you should see Desktop and Displays there will be a rotate option on it which shows pictures of different displays and not a drop down menu which doesn't seem to work for you.

IF that doesn't work it could be a driver issue, i wouldn't recommend messing with the registry unless you know what your doing as that could lead to further problems.

Posted 1 year ago
Top
 
kingamongthepigs
Posts: 8

Mine is HP Pavilion dv6-7000 , and as mentioned before, it's equipped with Nvidia 650M and Intel HD 4000.
All my drivers are up to date.
I just brought this PC like 3 days ago and I have Kaspersky Internet Security 2013 installed so I don't think there's that much chance for viruses.
All the hotkeys doesn't work. And as you can see from the screenshots, there's no option to rotate the screen where it should be.
I already backed up my registry before changing it so it's not that much of a problem. When I see it didn't work I changed it back too.
I'm gonna try Tuneup later. But I don't have high hopes on it.

Thanks for your help everyone. Any other suggestions?

Posted 1 year ago
Top
 
vistamike
vistamike
Posts: 10945

I would desist using tuneup. Programs like this can cause more problems than you started with.

If you really feel the need to have a cleanup then use the free version of this; http://www.piriform.com/ccleaner/download

As the machine is only 3 days old, I don't think this will solve much. Perhaps returning the machine under the warranty is the better option.

Mike

Posted 1 year ago
Top
 
RRRoman
Posts: 53

Well as far as I know the short cuts and the orientation option is provided by the Graphics Card drivers or the monitor, not the operating system. So I'd say check with you graphics card provider if you can download a driver or a utility that enables you the orientation option.

EDIT: I am also not sure if PhysX is the right thing to look at in this situations. I know that some of game developers utilize this engine provided by nVidia for their games, but I haven't really seen it being used much elsewhere.

Posted 1 year ago
Top
 
mu-tron
mu-tron
Posts: 7

My last post is probably best suted for people with AMD graphics cards not Nvidia 650M graphics cards even so i imagine the Nv650M has Software suited for the same purpose, changing Orientation in Screen Resolution menu but i'll see if i can figure out an other way.

Posted 1 year ago
Top
 
G41M
Posts: 902

Strange that the Nvidia Control Panel from the picture above does not have an option for the Display and Video options -only 3D settings. I would suggest uninstalling then reinstalling the Nvidia drivers. Uninstall it from the Programs and Features and NOT from the Device Manager. Also, do a "clean install" by checking the appropriate box during the Nvidia driver installation.

Posted 1 year ago
Top
 
mu-tron
mu-tron
Posts: 7

The Nvidia 650 and Intel HD 4000 isn't that two Graphics Cards, i'm not much of an expert on whether two Graphics Cards can be run at the same time but if that is the case there must be some sort of compatability issue i'd think, try disabling one of them its that or a drivers issue. Try switching your computer off/on.

I have found out you can run two Graphics Cards at the same time which would be good if you want to run more than two monitors, but it could be the reason for the rotate problem just disable one and see what happans.

Posted 1 year ago
Top
 
Ruja
Posts: 230

@mu-tron It is probably a Discrete Graphics setup, where the Intel HD is used except when Direct3D applications such as games are run, that put the nVidia in action. In some models you can choose (usually in the bios, maybe in another place) to work this way, or to force a certain graphics card to take over at all times. In some other models you can't choose that, I'm afraid. If you can force a single card on in the BIOS, maybe this rotate option comes back.

Anyways I think this discrete graphics solution is really bad at this time, it does not even work with OpenGL games or some 3D design software, which use the Intel HD. Heavy gamers should go with nVidia or ATI graphics, the rest of us should do OK with Intel HD graphics.

Posted 1 year ago
Top
 
kingamongthepigs
Posts: 8

I already have CCleaner installed and I've been using it from the start. Not that much help to this issue I think.
I tried uninstalling and reinstall Nvidia drivers but got the same results :(
Intel HD 4000 is Ivy Bridge integrated graphic card. Nvidia 650m have optimus technology which automatically switch between the two so there's hardly any chance that there's compatibility issue.
This isn't a faulty machine as far as I know. People with HP Pavilion Dv6-7000 are suffering from the same problem as well.
Wow everybody 've been a great help! Thanks for all the repies!
Any other solutions or work-around?
As I've mentioned before, I mostly work with Firefox when the screen needs to be rotated so if there's any add-on that can archive the same thing it's fine too. Or you can add to my greasemonkey code above to somehow solve the problem.

Posted 1 year ago
Top
 



Topic Closed

This topic has been closed to new replies.

Enter Your Email Here to Get Access for Free:

Go check your email!