SEARCH

The How-To Geek Forums Have Migrated to Discourse

How-To Geek Forums / Windows XP

(Solved) - Bootmgr is missing after plugging in an additional hard drive

(5 posts)
  • Started 1 year ago by sgx
  • Latest reply from G41M
  • Topic Viewed 977 times

sgx
Posts: 3

Hello,

This is my firs post. I purchased three IDE hard drives very cheap from ebay. The hard drives are supposed to be in working condition.
I tested them in my computer tower. One out of the three hard drives worked with no problems. For the other two I got the "bootmgr is missing" message at start up.
I did some research about this issue and I ended up burning an ISO Image (boot cd). I used this cd at start up and my computer was able to boot with the other hard drives plugged in.
My question is why did this happen? Does it mean the other two hard drives that don't work with the boot cd are broken in some way?
I'm running windows xp on the old hard drive. The three hard drives i purchased are used and come without OS. The jumper is set to cable select in my old hard drive and I tried the new ones with the jumper set to slave.
The BIOS boot sequence is set to CD ROM as first boot device, the old hard drive is the second, and the floppy drive is the third.
I hope this is not a stupid question :B
Thank you very much!

Posted 1 year ago
Top
 
G41M
Posts: 902

Try setting the old hdd (with the OS) as master and set as slave the drive w/o the OS. If you want to to configure using cable select, make sure both are jumpered as cable select and the drive with the OS plug into the farthest (other end) of the IDE cable and the drive without the OS in the middle connector. Personally, I prefer the master-slave setup.

Accepted Answer · Posted 1 year ago
Top
 
sgx
Posts: 3

Hello G41M,
Thanks for the quick response. I tried both configurations and I'm still getting the "bootmgr is missing" message. Once I put the boot cd into the cd-rom drive and restart, the computer boots with no problems. Does it have anything to do with the boot sequence? I currently have the CD-ROM as first, HDD1 as second and floppy drive as third.
Thanks again (:

Posted 1 year ago
Top
 
sgx
Posts: 3

Ok, I changed the boot sequence as follows: primary HDD0 second CD-ROM and third Floppy Drive.
I think the problem was that HDD1 was selected as boot device instead of HDD0.
I was able to test all three hard drives without using the boot CD.
Thank you very much for your help G41M.

Posted 1 year ago
Top
 
G41M
Posts: 902

Glad you sorted that out-:)

Posted 1 year ago
Top
 



Topic Closed

This topic has been closed to new replies.

Enter Your Email Here to Get Access for Free:

Go check your email!