SEARCH

The How-To Geek Forums Have Migrated to Discourse

How-To Geek Forums / Windows 7

(Solved) - BOOTMGR is missing

(9 posts)
  • Started 4 years ago by choobert
  • Latest reply from choobert
  • Topic Viewed 577 times

choobert
Posts: 5

I just installed Fedora 12 onto my free psace partition and now when i try to switch back to my Windows 7 partition it tells me my bootmgr is missing. I have tried both the restoring the startup and the command prompt bootrec /fixboot using the Windows 7 disk. How do i fix this problem?

Posted 4 years ago
Top
 
raphoenix
raphoenix
Posts: 14920

choobert,
---
Bootrec.exe options.
http://support.microsoft.com/kb/927392
---
Regards,
Rick P.

Posted 4 years ago
Top
 
Bhuttaz
Posts: 1

I am experiencing a similar problem, please advise. Thank you!

Posted 4 years ago
Top
 
choobert
Posts: 5

I used the link and used the cmd to use

Bootrec.exe /FixBoot

and after

Bootrec.exe
bcdedit /export C:BCD_Backup
c:
cd boot
attrib bcd -s -h -r
ren c:\boot\bcd bcd.old
bootrec /RebuildBcd

After this time it failed again, yet when i again used the Windows 7 disk it told me that it found a problem with the boot up and it would repair and restart. Natrually i clicked this and still i get BOOTMGR is missing with the only option of hittin CTRL-ALT-DELETE for restart

Posted 4 years ago
Top
 
raphoenix
raphoenix
Posts: 14920

choobert,
---
Do you have a FULL installation copy of Win7 or just a Restore copy ??

Posted 4 years ago
Top
 
choobert
Posts: 5

the full installation. the disk i used to install it in the first place.

Posted 4 years ago
Top
 
raphoenix
raphoenix
Posts: 14920

choobert,
---
My best advice is to download below, make CD, Nuke the HD and Clean Install Win7.
http://www.dban.org/download
---
Read this Guide to Dual Booting.
http://apcmag.com/the_definiti.....bystep.htm
---
Regards,
Rick P.

Posted 4 years ago
Top
 
choobert
Posts: 5

Well i have learned from another site that the problem is most likely that grub is loading /dev/sda3 instead of /dev/sda2 which i found via

su
fdisk -l
cat /boot/grub/grub.conf

however i do not understand how to change it. i am hoping this could be the solution as i do not want to reinstall windows. Thanks.

Posted 4 years ago
Top
 
choobert
Posts: 5

Bhuttaz, if you are having a problem like i was try this

su
fdisk -l
cat /boot/grub/grub.conf

to see which partition you need to boot windows 7. in my case grub was choosing the wrong one and thus it could not load. if this is the case, type the following.

gedit /etc/grub.conf

and then at the bottom it will say

title Other
rootnoverify (hd0,2)
chainloader +1

(with a number not necessarily 2) change it and save (you can also change Other to say Windows 7 if you like) and it should be fixed. Worked for me :)

Choobert

Accepted Answer · Posted 4 years ago
Top
 



Topic Closed

This topic has been closed to new replies.

Enter Your Email Here to Get Access for Free:

Go check your email!