SEARCH

The How-To Geek Forums Have Migrated to Discourse

How-To Geek Forums / Windows 7

Avast Antivirus free-I should take out Microsoft Security Essentials, right?

(13 posts)
  • Started 1 year ago by LeMarsMan
  • Latest reply from LeMarsMan
  • Topic Viewed 919 times

LeMarsMan
Posts: 314

Don't know why my Win7 is so slow in Firefox. I thought about trying Avast Antivirus Free. I assume I need to remove Microsoft Security Essentials first. Is that correct?

Thanks

LM

Posted 1 year ago
Top
 
Xhi
Xhi
Posts: 6298

That is correct. However, I do not see how that would speed up Firefox. I would suspect an errant add-on in Firefox rather than the anti-virus. There are also many speedier browsers, Chrome, Comodo, and Palemoon to name a few.

Posted 1 year ago
Top
 
vistamike
vistamike
Posts: 10945

MSE is so resource free, I'm surprised you are looking at Avast Av to correct win 7 slowing down.
Neither would affect Firefox.

Perhaps you could supply more details / specs of your machine( and your version of Firefox) to see if we can find a culprit

Mike

Posted 1 year ago
Top
 
LeMarsMan
Posts: 314

Firefox 17.0.1 Do I have to use the new addition of Firefox. I really do a lot of bookmarks. I have tried Chrome but didn't find the bookmakrs as usable.

I have:

Windows 7 Home Premium, Intel Core 2 Quad CUP Z9550 @2.83 GHZ, 8 GB of Ram, 64 bit operating system, Service Pack One, Solid State Drive

Any help highly appreciated.

LM

Posted 1 year ago
Top
 
StringJunky
StringJunky
Posts: 2454

I don't understand your original question. Is W7 running slow? Is FF running slow? Is it your internet speed? Your pc should fly with those specs so i'm wondering if it's your internet speed you are really having a problem with which is unconnected to the pc's spec.

Posted 1 year ago
Top
 
LeMarsMan
Posts: 314

Firefox=can really be slow. Computer-does not seem as fast as I would like.

Easy to measure internet speed?

Thanks

LM

Posted 1 year ago
Top
 
StringJunky
StringJunky
Posts: 2454

Do it three times and post back the results. Click "Begin Test"

http://www.speedtest.net/

Mine's Ping 89ms D/L 3.20Mb U/L 320Kb

This is fine...I can run Youtube without waiting to buffer first.

Posted 1 year ago
Top
 
vistamike
vistamike
Posts: 10945

Speedtest here; http://www.speedtest.net/ let us know readings against what you are paying for.

As a thought, unplug (unpower) your router for a good 5 mins with your machine shut down. Reboot router, reboot machine

Posted 1 year ago
Top
 
LeMarsMan
Posts: 314

Now, after signing up for speedtest.com I get this message:

The Adobe Flash Plugin has crashed

Irritating.

I will run the tests on Chrome.

LM

Posted 1 year ago
Top
 
vistamike
vistamike
Posts: 10945

speedtest will look at your connection either adsl or fibre, it does not charge.

'The Adobe Flash Plugin has crashed' is what other members are seeing too.

Uninstall Chrome
Uninstall flashplayer (all) reboot your machine

Posted 1 year ago
Top
 
LeMarsMan
Posts: 314

Test results after unplugging router, shutting down, etc.

Ping
20ms

Download Speed
5.00Mbps

Upload speed
.51 Mbps

How are these?

LM

Posted 1 year ago
Top
 
StringJunky
StringJunky
Posts: 2454

It's fine...the ping is four times faster than mine and download is twice as fast so your browsing should be pretty nippy.

Where are you experiencing the slowness? without being on the internet does your computer seem slow?

Right-click on your taskbar > start Task Manager > Click Performance Tab > Note your CPU Usage and Memory from the graphics. Don't have anything open when you do this.

Posted 1 year ago
Top
 
LeMarsMan
Posts: 314

That shows:

CPU usage is 0%
Memory is 2.21 GB

LM

Posted 1 year ago
Top
 



Topic Closed

This topic has been closed to new replies.

Get Free Articles in Your Inbox!

Join 134,000 newsletter readers

Email:

Go check your email!