SEARCH

The How-To Geek Forums Have Migrated to Discourse

How-To Geek Forums / Windows Vista

(Solved) - Autoplay not Working.

(24 posts)
  • Started 6 years ago by Patcaff
  • Latest reply from mach1guy
  • Topic Viewed 64146 times

Patcaff
Posts: 4

A friend has a new laptop running Vista Premium Home, the Autoplay has suddenly stopped working, have checked the autoplay setup in control panel and that's OK, but the optical disk or memory card reader autoplay doesn't respond, any idea's please.

Posted 6 years ago
Top
 
Lighthouse
Posts: 13598

Can you go back to a previous (before the problem started) restore point?

Posted 6 years ago
Top
 
Patcaff
Posts: 4

Oddly enough the restore doesn't appear to work either, but I take your point but I have tried that.

Posted 6 years ago
Top
 
jd2066
Posts: 3814

Can you still acess the cd drive and memory card reader in "Computer"?

Posted 6 years ago
Top
 
Patcaff
Posts: 4

Yes you can,and the drives do work in "manual"
but the Autoplay is useful.

Posted 6 years ago
Top
 
jd2066
Posts: 3814

Have you tried clicking the "Restore Defaults" button in the autoplay setup?

Posted 6 years ago
Top
 
Patcaff
Posts: 4

Yes I've done a "Restore Defaults" but no luck.

Posted 6 years ago
Top
 
whs
Posts: 17584

Did you try this:
1. Click the Start button, click All Programs, click Accessories, and then right-click Command Prompt.
2. Run as administrator.
3. At the command prompt, type "net start shellhwdetection" (without the quotes), and then press ENTER.
4. Restart your computer.

Posted 6 years ago
Top
 
nard79
Posts: 3

whs.
im having the same problem.i've done what u suggested above but it doesnt work. =(

Posted 6 years ago
Top
 
ScottW
Posts: 6609

nard79, let's have you check the Shell Hardware Detection service that whs points up. From an administrator command prompt, run the following commands and post back with the results:

> sc queryex shellhwdetection
> sc qc shellhwdetection

Posted 6 years ago
Top
 
alan5573
Posts: 12

Hi Scott.
I have the same problem, here are my results.
Microsoft Windows [Version 6.0.6001]
Copyright (c) 2006 Microsoft Corporation. All rights reserved.

C:\Users\Administrator>sc queryex shellhwdetection

SERVICE_NAME: shellhwdetection
TYPE : 20 WIN32_SHARE_PROCESS
STATE : 4 RUNNING
(STOPPABLE, NOT_PAUSABLE, ACCEPTS_SHUTDOWN)
WIN32_EXIT_CODE : 0 (0x0)
SERVICE_EXIT_CODE : 0 (0x0)
CHECKPOINT : 0x0
WAIT_HINT : 0x0
PID : 1024
FLAGS :

C:\Users\Administrator>sc qc shellhwdetection
[SC] QueryServiceConfig SUCCESS

SERVICE_NAME: shellhwdetection
TYPE : 20 WIN32_SHARE_PROCESS
START_TYPE : 2 AUTO_START
ERROR_CONTROL : 0 IGNORE
BINARY_PATH_NAME : C:\Windows\System32\svchost.exe -k netsvcs
LOAD_ORDER_GROUP : ShellSvcGroup
TAG : 0
DISPLAY_NAME : Shell Hardware Detection
DEPENDENCIES : RpcSs
SERVICE_START_NAME : LocalSystem

C:\Users\Administrator>

Posted 6 years ago
Top
 
ScottW
Posts: 6609

Alan, there's nothing wrong with your Autoplay service. Which devices do not Autoplay on your system? What do you see in Control Panel -> (Hardware and Sound) -> Autoplay ?

Posted 6 years ago
Top
 
alan5573
Posts: 12

Control panel is ticked for use autoplay for all media and devices. Putting a DVD in the player nothing launches although I can access it via explorer the same goes for my usb connected card reader. Both of these worked until a short while ago. The only thing that I can think of is that I recently had a bad case of malware which prevented windows updates and I had a lot of popups. I used Malwarebytes to remove those and as far as I can see the system is now clean.

Posted 6 years ago
Top
 
ScottW
Posts: 6609

Alan, in Control Panel -> Autoplay, the box is ticked, but what about all of the media types? If they are all set to "Take No Action" then nothing would happen.

After that, there are two other things to check. First, another program that wants to control that media could be intercepting the Autoplay. Any other media players, CD/DVD players or burners or whatnot running? Second, there is a group policy that can be used to disable Autoplay. If you have gpedit.msc, follow The Geek's instructions here in reverse:
http://www.howtogeek.com/howto.....sb-drives/

Otherwise, look for a key, NoDriveTypeAutoRun in both HKLM and HKCU at the following path:
\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer

Posted 6 years ago
Top
 
alan5573
Posts: 12

Scott, Control panel is fine and are all set correctly.

No programs are running that would cause a problem.

I do not have the "turn off autoplay" item in gpedit.msc.

The key you mention is present in both HKLM set to ff and HKCU set to 91

Posted 6 years ago
Top
 
ScottW
Posts: 6609

Alan, it is present? That's a problem, 0xFF = Disables Autoplay on all types of drives! See this TechNet article:
http://www.microsoft.com/techn.....x?mfr=true

The value 0x91 is a really odd value to see in Vista, 'cause it's the default for XP:
http://support.microsoft.com/kb/895108

But, it really doesn't matter since the HKLM value overrides the HKCU one. I wonder if your Malwarebytes program set these values to try to prevent reinfection? Also, why are the keys set, but not the Group Policy? Anyway, delete the keys and see if your Autoplay comes back.

Posted 6 years ago
Top
 
alan5573
Posts: 12

Scott, I think this is going to be one of those sticky ones. I deleted both keys and restarted. The first time I put a DVD in the drive the cursor changed to a disc and I thought we were in business but nothing further happened on subsequent tries no disc and no autostart.

Posted 6 years ago
Top
 
alan5573
Posts: 12

Scott, I found the local group policy it was under administrative Templates/windows components/autoplay policies they are set as follows:
Setting State
Turn off Autoplay Not configured
Don't set the always do this checkbox Not configured
Default behavior for AutoRun Not configured

I tried a few variations but no change.

Posted 6 years ago
Top
 
alan5573
Posts: 12

Scott, are these values correct.
Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\Explorer]
"NoDriveAutoRun"=dword:03ffffff
"NoDrives"=dword:00000000

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\Explorer\Run]

Posted 6 years ago
Top
 
ScottW
Posts: 6609

Alan, I have no experience with the Group Policy Editor, since I am running Vista Home Premium and XP Home. Maybe one of my fellow geeks can help.

As for the registry keys, NoDriveAutoRun means "disable autoplay" as far as I know. Maybe GP is putting the key back?

The NoDrives key hides drives from Computer and Explorer based on the bitmap. A value of 0 means hide nothing, but why is it even present? Sorry, but I have more questions than answers right now!

Posted 6 years ago
Top
 



Topic Closed

This topic has been closed to new replies.