The How-To Geek Forums Have Migrated to Discourse


How-To Geek Forums / Windows 7

Acer Empowerment Technology - Frameworklauncher not working in Windows 7

(1 post)
  • Started 7 years ago by rusty1
  • Topic Viewed 1467 times

PARTNER SPOTLIGHT

Recommended: Clean Your Mac the Easy Way with CleanMyMac 3

If you want to clean up your Mac the easy way, CleanMyMac is a great tool to get the job done easily, and it will even keep your computer clean automatically.

Unlike the competition, it also includes great tools like a Clean Uninstaller, to get rid of applications and clean up the junk that they leave behind. All with the click of a button.

Download CleanMyMac 3 for Free Today

Posted yesterday 
Top
rusty1
Posts: 1

Hi, Tried out Windows 7 and must say that it uses much less system resources than Vista which makes your hardware perform better. I did an upgrade on my Acer 6920G Vista notebook and everything seemed to work perfectly afterwards (Drivers and programs) APART from the built in Acer Empowerment Technology - Frameworklauncher. This very useful Acer backup / restore utility did not working in Windows 7, and also WarcraftIII (Frozenthrone III) would not run. Even after re-installation of the game. Apart from those 2, everything else looked fine.
After receiving very poor feedback from Acer, I am willing to find out why this usefull utility is not working anymore. Very surprised as everything else worked.

Any ideas??? I would love to switch to windows 7 in the future, but I have to resolve both above mentioned issues.

Keep up the good work! Any ideas....WELCOME!

Posted 7 years ago
Top
 



Topic Closed

This topic has been closed to new replies.