SEARCH

How-To Geek

DownThemAll! 2.0 Available – Now Supports Firefox 4.0

Advanced download extension DownThemAll! has released an updated version with new features, refinements, bug fixes, speed limits, mirror management, support for Firefox 4.0, and better platform/O.S. integration.

Note 1: A helpful about page will open in a new tab for those who may be new to using the DownThemAll! extension (about:downthemall).

Note 2: You will need to add the desired toolbar button(s) to your browser’s UI using the UI Customization Window.

DownThemAll! Homepage & Download

Download DownThemAll! [Mozilla Add-ons]

Features of DownThemAll!

Akemi Iwaya (Asian Angel) is our very own Firefox Fangirl who enjoys working with multiple browsers and loves 'old school' role-playing games. Visit her on Twitter and .

  • Published 01/18/11

Comments (5)

  1. Santo

    This version is not compatible with Firefox 3.6.16(Ubuntu). Except the Mozilla web link other two links don’t seem to be working.

  2. AsianAngel

    @Santo – The screenshot shown above is from my Firefox 4.0 install, but the extension installed perfectly well on my 3.6 browser too (both are on Ubuntu). So I am at a loss as for why it would not install for you. :(

    As for the main website I am also unable to access it at the moment (unlike earlier)…

  3. Ubuntuinstall

    Works OK on my Ubuntu 10.10 Firefox 3.6

  4. Matthew Guay

    Nice … DownThemAll is one of the main reasons I keep Firefox installed even though I mostly use Chrome. It’s that good!

  5. AsianAngel

    @Matthew Guay – ^_^ Have you used Firefox 4.0 beta 9 much since it came out? It is totally wonderful and I am already using it full-time. ^_^

Get Free Articles in Your Inbox!

Join 134,000 newsletter readers

Email:

Go check your email!